BTS

Issue1270

Title grml-rescueboot does not support md/raid devices
Priority bug Status resolved
Superseder Nosy List faheem, mika, thinkgear
Assigned To mika Topics

Created on 2013-09-04.12:24:43 by thinkgear, last changed 2013-10-16.21:04:46 by mika.

Files
File name Uploaded Type Edit Remove
rescueboot-failure-or-raid.zip thinkgear, 2013-09-04.12:24:43 application/zip
Messages
msg4659 (view) Author: mika Date: 2013-10-16.20:58:17
* thinkgear wrote in grml's BTS on 20131016 / 21:54:

> I confirm that grml64-full_testing_20131016.iso works fine.

> Mika, thanks for resolving this issue.

Jippie! Thanks for verification and feedback!

regards,
-mika-
msg4658 (view) Author: thinkgear Date: 2013-10-16.19:54:57
I confirm that grml64-full_testing_20131016.iso works fine.

Mika, thanks for resolving this issue.
msg4657 (view) Author: faheem Date: 2013-10-16.15:04:31
On Tue, 15 Oct 2013, Michael Prokop wrote:

>
> Michael Prokop <mika@grml.org> added the comment:

> * Faheem Mitha wrote in grml's BTS on 20131015 / 18:26:

>> Does that mean that issue 971 should be closed as well?

> Hm, issues 971 was already closed on 2011-08-04 20:21:14, but AFAICS
> it re-appeared since the code from debian-live's live-boot broke
> between back then and until my fix of today. So nothing to do. :)

Ok Michael,

Thanks. Good to know it is working. Maybe I'll give it a try myself some 
time.

                                                          Regards, Faheem

> regards,
> -mika-
>
> _____________________________________
> GRML issue tracker <bts@bts.grml.org>
> <http://bts.grml.org/grml/issue1270>
> _____________________________________
>
>
>

Under the two moons of Hydrot, and under the eternal stars, the
two-inch wooden spaceship and its microscopic cargo toiled down the
slope toward the drying little rivulet.
--
James Blish - Surface Tension
msg4656 (view) Author: mika Date: 2013-10-15.21:15:05
* Faheem Mitha wrote in grml's BTS on 20131015 / 18:26:

> Does that mean that issue 971 should be closed as well?

Hm, issues 971 was already closed on 2011-08-04 20:21:14, but AFAICS
it re-appeared since the code from debian-live's live-boot broke
between back then and until my fix of today. So nothing to do. :)

regards,
-mika-
msg4655 (view) Author: faheem Date: 2013-10-15.16:26:21
On Tue, 15 Oct 2013, Michael Prokop wrote:

> Michael Prokop <mika@grml.org> added the comment:

> Fixed in git:

> https://github.com/grml/live-boot-grml/commit/3d46167c4f419479f09a4c8bc1025e6f2248b2d5

> Will be closed by upload of new live-boot version.
> The daily ISOs as of tomorrow should include this fix and therefore provide
> working ISOs, I'd appreciate feedback from the bug reporter.

> Thanks for providing the VirtualBox VM!

Does that mean that issue 971 should be closed as well?

                                        Regards, Faheem

> regards,
> -mika-
>
> ----------
> assignedto:  -> mika
> nosy: +mika
> status: chatting -> fixed-in-git
>
> _____________________________________
> GRML issue tracker <bts@bts.grml.org>
> <http://bts.grml.org/grml/issue1270>
> _____________________________________
msg4654 (view) Author: mika Date: 2013-10-15.15:15:34
We believe that your issue has been closed by the upload of
Version 4.0~a13-1+grml.4 of live-boot from Michael Prokop <mika@grml.org>.
The explanation is attached below

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Tue, 15 Oct 2013 16:58:17 +0200
Source: live-boot
Binary: live-boot-grml live-boot-grml-doc live-boot-grml-initramfs-tools
Architecture: source all
Version: 4.0~a13-1+grml.4
Distribution: unstable
Urgency: low
Maintainer: Grml Team <team@grml.org>
Changed-By: Michael Prokop <mika@grml.org>
Description: 
 live-boot-grml - Live System Boot Scripts
 live-boot-grml-doc - Live System Boot Scripts (documentation)
 live-boot-grml-initramfs-tools - Live System Boot Scripts (initramfs-tools backend)
Changes: 
 live-boot (4.0~a13-1+grml.4) unstable; urgency=low
 .
   * [3d46167] Add patch to properly boot from mdadm via findiso boot
     option [Closes: issue1270] Thanks to thinkgear for the bug report
     and providing a test VM
Checksums-Sha1: 
 b3fedd0146e5a8fea9fbf811c1ac8af7b46f9c47 1396 live-boot_4.0~a13-1+grml.4.dsc
 cb49ef96c8bfd82f3ca4707ab53305dc33963cc9 37304 live-boot_4.0~a13-1+grml.4.debian.tar.xz
 1aed8a580d24a39f8abbbd7a7e4f8a7a5b439763 56734 live-boot-grml_4.0~a13-1+grml.4_all.deb
 d843609b7689e471d451e7b09c7556197db7e1a7 55814 live-boot-grml-doc_4.0~a13-1+grml.4_all.deb
 09aca388efe98fcf745b7cfffdb9d2873a66a908 30970 live-boot-grml-initramfs-tools_4.0~a13-1+grml.4_all.deb
Checksums-Sha256: 
 a68c41daa522c2fc5fdc6240d594d2d264b1f227b90761285de79b60685b68ca 1396 live-boot_4.0~a13-1+grml.4.dsc
 bfa6c342521329a29cbb161e87af41caafd283cf1f52342e4257050bd8468c2e 37304 live-boot_4.0~a13-1+grml.4.debian.tar.xz
 7fc82e2daec09437a5209ff1a2f29580a7a600ed908926dc1ab268361953fe72 56734 live-boot-grml_4.0~a13-1+grml.4_all.deb
 db2299d39dd69197c1c220f7d6962a7e3668a3141d0915b1b729be3652f60d55 55814 live-boot-grml-doc_4.0~a13-1+grml.4_all.deb
 c9128b44c1c56986b2ca24c2491fd395d7bedf24a196eb1b48a575fbb029dfee 30970 live-boot-grml-initramfs-tools_4.0~a13-1+grml.4_all.deb
Files: 
 acb964b21c5103e55b2d64fe804ed61e 1396 misc optional live-boot_4.0~a13-1+grml.4.dsc
 20201d7326205b7f1ac2a9902c8cd1d5 37304 misc optional live-boot_4.0~a13-1+grml.4.debian.tar.xz
 daf739e12a772b3ae9d2c6435c5d7fc2 56734 misc optional live-boot-grml_4.0~a13-1+grml.4_all.deb
 50ba2d22a1898726a8565dc1a0f9944b 55814 doc optional live-boot-grml-doc_4.0~a13-1+grml.4_all.deb
 1a7f6ab9e5120295cd6db90c2c7bf1b3 30970 misc optional live-boot-grml-initramfs-tools_4.0~a13-1+grml.4_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAlJdWKsACgkQ2N9T+zficuhEDgCeLq/nmwmv15OuF44yDuBCIZmx
AQ0AnjJllJ75PZ7ahTk9smJH18sUc98+
=zORQ
-----END PGP SIGNATURE-----
msg4653 (view) Author: mika Date: 2013-10-15.15:02:51
Fixed in git:

 
https://github.com/grml/live-boot-grml/commit/3d46167c4f419479f09a4c8bc1025e6f2248b2d5

Will be closed by upload of new live-boot version.
The daily ISOs as of tomorrow should include this fix and therefore provide
working ISOs, I'd appreciate feedback from the bug reporter.

Thanks for providing the VirtualBox VM!

regards,
-mika-
msg4635 (view) Author: mika Date: 2013-09-26.22:30:38
* thinkgear wrote in grml's BTS on 20130926 / 22:13:

> I have created a VirtualBox guest with Debian Wheezy and grml-2013.09-rc1 to 
> demonstrate the grml boot failure with grml-rescueboot on raid (/boot on /dev/
> md0 and luks-encrypted root on /dev/md1) as shown in the screenshots of 
> 2013-09-04.

> If you send me a private email, I will reply with the link for the download of 
> a rather large tar.bz2 file containing the VirtualBox guest.

Wow, that's fantastic, awesome! Will f'up per private email, thanks!

regards,
-mika-
msg4634 (view) Author: thinkgear Date: 2013-09-26.20:13:09
I have created a VirtualBox guest with Debian Wheezy and grml-2013.09-rc1 to 
demonstrate the grml boot failure with grml-rescueboot on raid (/boot on /dev/
md0 and luks-encrypted root on /dev/md1) as shown in the screenshots of 
2013-09-04.

If you send me a private email, I will reply with the link for the download of 
a rather large tar.bz2 file containing the VirtualBox guest.
msg4616 (view) Author: mika Date: 2013-09-16.08:45:38
* thinkgear wrote in grml's BTS on 20130913 / 20:26:

> Problem persists with grml64-full 2013.09-rc1. Error messages identical to grml-
> lastest-testing-20130904 (see screenshots uploaded 2013-09-04).

Thanks a lot for checking, this definitely helps us in digging
deeper into the issue.

regards,
-mika-
msg4615 (view) Author: thinkgear Date: 2013-09-13.18:26:36
Problem persists with grml64-full 2013.09-rc1. Error messages identical to grml-
lastest-testing-20130904 (see screenshots uploaded 2013-09-04).
msg4603 (view) Author: mika Date: 2013-09-04.15:12:51
Good to know - that should help in investigating, thanks!
msg4602 (view) Author: thinkgear Date: 2013-09-04.15:10:12
This happened on real hardware first. Subsequently I created a VirtualBox 
guest. Boot behaviour and error messages are identical on real and virtual 
hardware.

I also tested with Debian Squeeze and Wheezy, but again results are identical.

I am using grml-rescueboot successfully on other system without RAID.
msg4601 (view) Author: mika Date: 2013-09-04.14:59:57
Thanks for testing! Hm ok, so this might be specific to your system then, would 
be interesting whether we can set up a reproducible system in a virtual machine 
or so....
msg4600 (view) Author: thinkgear Date: 2013-09-04.12:54:26
In addition to grml-2013-02 and grml-lastest-testing-20130904 I also tried 
grml-2011-12 without success on RAID1.
msg4599 (view) Author: mika Date: 2013-09-04.12:44:00
Sorry, overread your "grml-latest-testing (2013-09-04)". Would be interesting to 
know which ISO worked and why it's broken nowadays.
msg4598 (view) Author: mika Date: 2013-09-04.12:43:19
Can you please test it with a current daily ISO from daily.grml.org?
msg4597 (view) Author: thinkgear Date: 2013-09-04.12:24:43
Copy of issue 971

grml iso is not found when /boot is located on /dev/md0.

Fresh install of Debian Wheezy. /boot is located on /dev/md0, a RAID1 device 
located on /dev/sda1 and /dev/sdb1. Error message depends on the grml iso used:

grml-2013-02 fails with "mount aufs on /root..." message and drops to initramfs 
shell. /dev/md0 is not mounted.

grml-latest-testing (2013-09-04) drops to an initramfs shell too, but here /dev/
md0 is mounted. It looks like here only the timeout before it drops to a shell 
is too short.

Screenshots with all error messages attached.
History
Date User Action Args
2013-10-16 21:04:46mikasetstatus: chatting -> resolved
nosy: mika, faheem, thinkgear
2013-10-16 20:58:17mikasetstatus: resolved -> chatting
nosy: mika, faheem, thinkgear
messages: + msg4659
2013-10-16 19:55:32thinkgearsetstatus: chatting -> resolved
nosy: mika, faheem, thinkgear
2013-10-16 19:54:57thinkgearsetstatus: resolved -> chatting
nosy: mika, faheem, thinkgear
messages: + msg4658
2013-10-16 15:38:36mikasetstatus: chatting -> resolved
nosy: mika, faheem, thinkgear
2013-10-16 15:04:31faheemsetstatus: resolved -> chatting
nosy: mika, faheem, thinkgear
messages: + msg4657
2013-10-16 07:12:45mikasetstatus: chatting -> resolved
nosy: mika, faheem, thinkgear
2013-10-15 21:15:05mikasetnosy: mika, faheem, thinkgear
messages: + msg4656
2013-10-15 16:26:21faheemsetstatus: resolved -> chatting
nosy: mika, faheem, thinkgear
messages: + msg4655
2013-10-15 15:15:34mikasetstatus: fixed-in-git -> resolved
nosy: mika, faheem, thinkgear
messages: + msg4654
2013-10-15 15:02:51mikasetstatus: chatting -> fixed-in-git
assignedto: mika
messages: + msg4653
nosy: + mika
2013-09-26 22:30:38mikasetmessages: + msg4635
2013-09-26 20:13:09thinkgearsetmessages: + msg4634
2013-09-16 08:45:38mikasetmessages: + msg4616
2013-09-13 18:26:36thinkgearsetmessages: + msg4615
2013-09-04 15:12:52mikasetmessages: + msg4603
2013-09-04 15:10:12thinkgearsetmessages: + msg4602
2013-09-04 14:59:57mikasetmessages: + msg4601
2013-09-04 12:54:26thinkgearsetmessages: + msg4600
2013-09-04 12:44:00mikasetmessages: + msg4599
2013-09-04 12:43:19mikasetstatus: unread -> chatting
messages: + msg4598
2013-09-04 12:24:43thinkgearcreate