Title grml 2012.05 runs DHCP actions in foreground causing delays during booting
Priority bug Status resolved
Superseder Nosy List mika
Assigned To mika Topics

Created on 2012-05-29.20:43:13 by mika, last changed 2012-06-22.21:45:08 by mika.

msg4396 (view) Author: mika Date: 2012-06-22.21:45:08
This issue has been fixed with upload of ifupdown 0.7.
msg4371 (view) Author: mika Date: 2012-05-29.20:43:12
As spotted by Zhenech the 2012.05 release runs DHCP configuration in foreground
instead of running it in the background and therefore causing delays especially
on systems with multiple NICs or no useable DHCP infrastructure at all.

This bug is caused by ifupdown:

Workaround for the time being: add the "nonetworking" boot option to disable
network configuration during bootup, devices can be configured later on as usual
(netcardconfig, ifconfig,...).
Date User Action Args
2012-06-22 21:45:08mikasetstatus: in-progress -> resolved
assignedto: mika
messages: + msg4396
2012-05-29 20:43:13mikacreate